Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 03, 2025 - 07:00 UTC
Scheduled
We will undergo a routine maintenance on 2025-03-03 7:00 AM (UTC +0), that will take approximately 1 hour. Some services might not be available during the maintenance. We apologise for the inconvenience caused.
Posted Mar 02, 2025 - 11:52 UTC
This scheduled maintenance affected: Web (Mainnet), Web (Testnet), API (Mainnet), and API (Testnet).